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1. Generality

1.1. Document releases

Revision Date Pages Comments

1.00 16/07/2003 10 First edition

1.01 03/12/2003 10 Add: Forced FW download and new logo’s windows
1.02 15/12/2003 13 Added setup

1.03 11/02/2004 18 New setup features and memory parameters

1.04 09/07/2004 18 Added Download Tool description

1.2. Reference documents

Reference Name Description
1 Printer Configuration Tool.pdf Printer Configuration Tool User’s Guide
2 PRT100_lInstallation.pdf Installation Kit User’'s Guide

1.3. Conventions

Example Description

(s 1) Reference document number. Es. (e 1) Means first document of the eference documents
list.
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2. Introduction

This document describes the Resource Kit application. It is a collection of tools that allows the user to configure

the printer.

The tools now available are:

7

NN BN

Download Firmware: To update the printer FWs

Download Logo: To memaorize logos in the printer memory

Printer Setup: To change the printer setup

Memory Maintenance: To upload the factory and user memory parameters

The application can run in local or in a network installation (e 2). So it works with printers plugged on the same
PC where the application is running or in another PC in the local network previously configured using the Printer
Configuration Tool (e 1).
NOTE: before working with the Resource Kit it is necessary to configure the printer using the Printer
Configuration Tool (& 1).

3. Select Language Window

When the Resource Kit starts it shows a window to select the languages.
If there is only one language available this window will be not displayed.

P Resource Kit 5 x|

I_IIIIL IWIETTHE
MECNOST

Choose lanquage

fel--

[T Set as default

5 Prewious I Mewut > I Cancel i

Clicking the “Next” button the “Select Tool Window” will be shown
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4. Select Tool Window
B Resource Kit |z|

ILIWETTE
TIMMECNICOST

1
el

,?.._j Download firrmware

Choose tool application PRT 100

¢ Previous End

Cancel Help

This window allows the user to select the tool to run.
The tools available are:

7

NN N

Download firmware.
Download Logo.

Printer Setup

Load memory parameters
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5. Download firmware

The “Download firmware” tool allows to upgrade the FW of the installed printers.
The first window shows is the following:

B4 PosRK - FW Download [ X

File Wiew Toals

SWDRY-7-W2ZK

.,f PRT100:COM1
PRT100:COMZ

MS on SWDRM-T-W2K |Ready...

This window shows all the printers installed in the system. The printers have to be previously installed using the
the Printer Configuration Tool (& 1).

The “File” menu allows to select the kind of firmware to download.
The possible choices are:

?? Boot Download: to download the boot section

?? FW Download: To download the program and font section
?? Forced Download:

o0 Boot Download: to download the boot section in forced mode

o FW Download: To download the program and font section in forced mode

The “Tools” menu allows to add or remove another server where the printers may be installed.

In order to start the download procedure need:

1. Select the printer/printers, of the same model, where the FW need to be upgraded. It is possible to

select one or more printers, locally plugged or in the network, and the tool is able to download the FW to
the selected printer in the same time.

2. Select in the “File” menu the FW to download

After these steps, before starting the download, the tool calculates the FW checksum shows the following
confirmation window:
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PosREKFWDwld |
1 IPosREIPRT 100FW resid, bin
Checksum: 0293, Continue?

Carncel |

Clicking “OK” the procedure starts and the progress bars show the status of the download:

£ posRK - FW Download R EI

File Wiew Tools

s = SWDRV-7-W2K
Fl&g PRT100:C 0N mm— |
-------------- [Fl&# PRT100:CONMmm— |

MS on SWDRM-7-W2K | Waiting...

When the download is completed or an error occurs, the progress bar is removed and a message is displayed in
the same place.

NOTE: to perform the FORCED DOWNLOAD of Boot/Firmware, it is necessary to

set the printer as described in the procedure below.

- disconnect the printer from the power supply and open the cover

- check that the paper roll is present.

- press and hold switch button and paper feed button together.

- connect to the power supply the printer, while holding down the two buttons and close the
cover.

- release both buttons.

- the green led (printer on) must be on. If not repeat the procedure from the beginning.
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5.1. Download Tool

The Download Tool allows to download the FW in batch mode. The tool is compose by two files:
?? DwldTool.exe: exe file
?? DwildTool.ini: Configuration file.

The Configuration file has the [DWLDPARAM] sectin in which it is possible to configure the following
parameters:

?? INTERACTIVE The possible values are:
o N: The download is done without any confirmation by the user
o0 Y: A confirmation pop-up is shown
?? FORCED: The possible value are
o N: The tool executes a standard download
0 Y: The tool executes a forced download
?? PRINTER: Select the printer and the port where execute the download. Possible values are

o PRT100:COM1, PRT100:COM2 .... PRT100:COMS8, PRT100:LPT1, PRT100:LPT2,
PRT100:USB001, PRT100:USB002

o PRJ12:COM1, PRJ12:COM2 .... PRJ12:COMS8, PRJ12:LPT1, PRJ12:LPTZ,
PRJ12:USB001, PRJ12:USB002

FILEPATH: The folder where the FW is stored

FILECS: FW checsum=6E75

FILETYPE: The file type field can ha the following values:
o BOOT: For boot download
o FW: For FW download

NN BN

Example:

[DWLDPARAM]

INTERACTIVE=N

FORCED=N

PRINTER=PRT100:COM1
FILEPATH=C:\JPosRK\PRJ12\FW\bt100v07.bin
FILECS=6E75

FILETYPE=BOOT

6. Download Logo

This tool allows to download logos on the selected printer. This tool can work locally or can address a printer in
the network, but the logo download can address one printer at time.

In the first window it is possible to select the printer to address in the download procedure.
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£ pOS Logo ver. 1.0.0 i =100 =]

File Wiew Help

=] SWDRY-7-W2K

g PRT100:COM1

PRT100:COM2Z

LOCAL |Ready...

After selecting a printer the program will display the following window
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Al Togos | Clear logo mermary

Print all merory
|logos

Add lagao

Select all

Select none

Lelete logo

Cownload logo

Frint looa

"m Used memon———————— " m Free memony———————————

Close

| Printer ready... |F‘~Ead‘f---

Working with the PRT100 printer it's not possible to ask to the printer how many logos has already in memory,
so this window, that should show a thumbnail for each logo in memory is empty.

Pressing the “Add Logo” Button it is possible to browse in the PC directories to select one or more BMP files to
use as logos.

The select files will be shown as thumbnail in the window. For each file is created also a new page (New(1),
New(2)...New(N)).

After that it is possible to select, clicking on the related thumbnails the logos to send to the printer using the
“Send Logo” button.

The logos are not printed immediately but are stored in the printer memory.
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X

all logos | Mew(l) I

Ir::E NT20

Mew{l)

"ﬁ Lzed

MEemory

ﬁ Free memamny———

Zlear logo meriary

Print all mernory
logos

Add logo

Select all

Zelect none

Delete [ogo

Cownload logo

Frint looa

Close

| Printer ready.

i |Rea|:|3r...

Selecting the New(x) page it is possible to modify the logo image as shown in the following window

Zlear logo meriory

Original image

CENTRO

Preview

—FPaper width

IBI] mm

[T Fitto papetwidth

CEN

E

—Colar

|Black & white

[~ Etrar diffusion

|

E

Print all mermory
logos

add logo

Zelect all

Select none

Delete logo

Cownload logo

Print logo

Close

| Printer ready,

.. |Ready...

Using the print logo is it possible to print immediately the logo without storing it.
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7. Printer Setup

The “Printer Setup” tool allows upgrading the setup of the installed printers.

The first window shows is the following:

& PosRK - Setup

Load setup file
from disk

Create setup file

Enter printer setup

Exit

Using this window it is possible to select the feature to use:
?? Load setup from disk

?? Create setup file

?? Enter printer setup
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7.1. Enter printer setup

After selecting a printer the program will display the window with all the setup parameter:

& PosRK - Setup |- || I&|
File Wiew Help

@ Printer:COM3
@ PRT100:COM1
@ PRT100:USB0D2

LOCAL | Ready...

| PosRK - Setup for PRT100

1} CONFIGURAZIONE
+#-- "] ROLL WIDTH

g ‘:J Ifu

MATIOM

CPI

CUTTER
DENSITY
DISPLAY
AUTO LF
RECEIYE BUFFER
BUSY OFFLIME
TOF POSITION
OPTIMIZE FOR

__+___+___+___+___+___+___+___+___+___+___++
Srosaraenaaracef

= ]

[BOOT 4.00v007 P 4.00B009 | Ready...

The setup is represented as a tree.
Clicking on the menu’s items it is possible to open the folder to view the parameters.
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Clicking on the radio button it is possible to select a parameter.

EEX

)E} SERIAL
BIT

¥ BAUD
¥ STOP

¥ PARITY

¥ HANDSHAKE

¥ RX ERROR

'j O PARALLEL OR DTHER

#-] NATION

#- ] CPI

# ] CUTTER

# ] DENSITY

# ] DISPLAY

# ] AUTO LF

+# ] RECEIVE BUFFER
# ] BUSY OFFLINE

# ] TOF POSITION

+# ] OPTIMIZE FOR

1 BOOT 4.00v007 Fw 4.00B003  Ready...

At this point, using the “File” menu it is possible to perform the following actions:

?? Download to download the setup to the printer

?? Save to save the setup on file
?? Exit from the program

Using the option “Refresh” in the “View” menu it is possible to re-load the setup from the printer.
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7.2. Load setup from disk

This feature allows loading a setup file previously generated, modifying the file and downloading it to the printer.
The printer recognizes the settings and update itself.

Load setup file

Look jri | <ee XPEDATA (D) ~| = @&k E-
K ) Clivetti

ﬁ 3 ProveSmartCard
MpRecent  |ZZProveTOOLKIT
Diocurnents B quiki

"E |)smartcard

Systern Yolume Information
Dezktop

by Computer
My Metwork  File name: ||:uru:wa.st|:u L] Open
Flaces
Files of type: |5TF' Files [ ztp) j Cancel |

The setup files have a proprietary file format recognized by the .stp extension.
After choosing the file the following window is shown:
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. PosBK - Setup for PRT100
File

5] CONFIGURAZIONE
+ ROLL WIDTH
I,ru

NATION

CPI

CUTTER
DENSITY
DISPLAY
AUTO LF
RECEIYE BUFFER
BUSY OFFLINE
TOF POSITION
OPTIMIZE FOR

+
+
+
+
+
+
|
+
+
+
+
+

1 Ready”.

At this point it | possible to modify the file and/or, using the “File” menu to perform the following actions:

?? Download the file to the printer

?? Load a new setup file
?? Save the setup file
?? Exit from the program
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7.3. Create setup file

In order to generate a new setup file it is necessary to load the setup from the reference printer and save it to
the file:

& PosRK - Setup
File ‘Wiew Help

@ Printer:COM3
4§ PRT100:COM1
4§ PRT100:USB0Z

LoCal | Ready...

After selecting a printer the program will display the window with all the setup parameter:

= PosRK - Setup for PRT100 =3

1l CONFIGURAZIDNE
“] ROLL WIDTH
j Ijo

NATION

CPI

CUTTER
DENSITY
DISPLAY
AUTO LF
RECEIYE BUFFER
BUSY OFFLINE
TOF POSITION
OPTIMIZE FOR

TS T T T TS |

= ]

|[BOOT 4.00v007 | Fw 4.00B009 | Ready..,

At this point, using the “File” menu it is possible to perform the following actions:
?? Download to download the setup to the printer
?? Save to save the setup on file
?? Exit from the program
Using the option “Refresh” in the “View” menu it is possible to re-load the setup from the printer.
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8. Memory parameters

This tool allows loading and updating the printer memory parameters.
The first step is to select the printer:

&% PosRK - Memory
File Wiew Help
ClrgoLIGOLD

LOCAL IReady... 5

After that the printer parameters are shown:

= PosRK - Memory PRT100

Filee Wiew

M_pmur!_.r Maintenance
#- ] FACTORY
#-] USER

11 \BOOT 4.00v007 |Fi 4.00B009 | Ready... >

It is possible to see both the factory and user parameters:
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w. PosPK - Memory PRT100 [Z“§|E|
Fil=  Wiew
- FACTORY 5

7] ID PRINTER=
-Ej Mumber Of Char=0D
-E3 Line Feed=1411
-E3 Cut executed=73
-E3 Roll Changes=2
-Ej Power On=54
-E3 Hour worked=0
-7 USER
t ID PRINTER=PRT100-2
t Mumber Of Char=0
t Line Feed=1411
¥ Cut executed=73
t Roll Changes=2
¥ Power On=>54
—# Hour worked=0

11 BOOT 4.00v007 |Fu 4.00B009 | Ready...

The factory parameters cannot be changed. The user parameters can be modified a follows:
1. The ID PRINTER can be changed
2. All the other user’'s parameters can be only set to 0

In order to change the parameter’s values it's enough to click in the tree on the parameter item.
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